#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(^header2[\s\S]+?(?=^header|\Z))"
Local $sString = "# output could containmultiple headers, and lines, or no lines per header this is an example of what could be present but it is not absolute. " & @CRLF & _
"" & @CRLF & _
"header1" & @CRLF & _
"-------" & @CRLF & _
"line1" & @CRLF & _
"line2" & @CRLF & _
"line3 # can be muiplies availables or known" & @CRLF & _
"" & @CRLF & _
"header2" & @CRLF & _
"-------" & @CRLF & _
"line1" & @CRLF & _
"line2" & @CRLF & _
"line3 # can be muiplies availables or known" & @CRLF & _
"" & @CRLF & _
"header3" & @CRLF & _
"-------" & @CRLF & _
"" & @CRLF & _
"header4" & @CRLF & _
"-------" & @CRLF & _
"line1" & @CRLF & _
"line2" & @CRLF & _
"line3 # can be multiple linnes or none not known "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")