#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?:silence|black)_(?:start|end|duration):\s*\d+(?:\.\d+)?\b"
Local $sString = "ffmpeg version 4.2.2 Copyright (c) 2000-2019 the FFmpeg developers" & @CRLF & _
" built with Apple clang version 11.0.0 (clang-1100.0.33.17)" & @CRLF & _
" configuration: --prefix=/usr/local/Cellar/ffmpeg/4.2.2_3 --enable-shared --enable-pthreads --..." & @CRLF & _
"[silencedetect @ 0x7fdd82d011c0] silence_start: 0" & @CRLF & _
"frame= 112 fps=0.0 q=-0.0 size=N/A time=00:00:05.00 bitrate=N/A speed=9.96x " & @CRLF & _
"[blackdetect @ 0x7fdd82e06580] black_start:0 black_end:5 black_duration:5" & @CRLF & _
"[silencedetect @ 0x7fdd82d011c0] silence_end: 5.06285 | silence_duration: 5.06285" & @CRLF & _
"frame= 211 fps=210 q=-0.0 size=N/A time=00:00:09.00 bitrate=N/A speed=8.97x " & @CRLF & _
"frame= 319 fps=212 q=-0.0 size=N/A time=00:00:13.00 bitrate=N/A speed=8.63x " & @CRLF & _
"frame= 427 fps=213 q=-0.0 size=N/A time=00:00:17.08 bitrate=N/A speed=8.51x " & @CRLF & _
"frame= 537 fps=214 q=-0.0 size=N/A time=00:00:22.00 bitrate=N/A speed=8.77x " & @CRLF & _
"frame= 650 fps=216 q=-0.0 size=N/A time=00:00:26.00 bitrate=N/A speed=8.63x " & @CRLF & _
"frame= 761 fps=217 q=-0.0 size=N/A time=00:00:31.00 bitrate=N/A speed=8.82x " & @CRLF & _
"frame= 874 fps=218 q=-0.0 size=N/A time=00:00:35.00 bitrate=N/A speed=8.71x " & @CRLF & _
"frame= 980 fps=217 q=-0.0 size=N/A time=00:00:39.20 bitrate=N/A speed=8.67x " & @CRLF & _
"... " & @CRLF & _
"frame= 5680 fps=213 q=-0.0 size=N/A time=00:03:47.20 bitrate=N/A speed=8.53x " & @CRLF & _
"[silencedetect @ 0x7fdd82d011c0] silence_start: 227.733" & @CRLF & _
"[silencedetect @ 0x7fdd82d011c0] silence_end: 229.051 | silence_duration: 1.3184" & @CRLF & _
"[silencedetect @ 0x7fdd82d011c0] silence_start: 229.051" & @CRLF & _
"[blackdetect @ 0x7fdd82e06580] black_start:229.28 black_end:230.24 black_duration:0.96" & @CRLF & _
"frame= 5757 fps=214 q=-0.0 Lsize=N/A time=00:03:50.28 bitrate=N/A speed=8.54x " & @CRLF & _
"video:3013kB audio:43178kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown" & @CRLF & _
"[silencedetect @ 0x7fdd82d011c0] silence_end: 230.28 | silence_duration: 1.22856"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")