import re
regex = re.compile(r"^(?:([\p{Lu}0-9_]{2,})|(\p{Lu}[\p{L}0-9_$]+)|([\p{L}_$][\p{L}0-9_$]*))\b", flags=re.MULTILINE)
test_str = ("HELLO\n"
"Hello\n"
"hello\n"
"A\n"
"AClass\n"
"b\n"
"BCONST\n"
"$helloWorld\n"
"$GoodbyeWorld\n"
"$WHATUPWORLD\n"
"101Regex\n"
"neel@computer.local")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")