re = /^\w+(?:[.-]\w+)*@\w+(?:[.-]\w+)*(?:\.\w{2,3})+$/m
str = 'somethingverylong@hereandthereseemore-.com
somethingverylong@hereandthereseemore.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end