re = /(?<!\\)~~~(?! ).*?(~~~)/m
str = '~~~CREATE TAG TABLE - NEED ONLY ONE~~~
~CREATE TAG TABLE - NEED ONLY ONE~'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end