using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^.*/[^/]*(create|update|delete)[^/]*$";
string input = @"/some/path
/create/too/early
/create
/update_something
/some/path/delete
/some/path/create_something";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}