package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`[^a-zA-Z-]+`)
var str = `, ,, ford, tempo, with,,, sunroof,, ,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}