using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"ErrorMessage\=\s+(?<ErrorMessage>.*)";
string input = @"Number=Test1,Code=DPCA , ErrorMessage= sun.security.validator.ValidatorException: PKIX path building failed: sun.security.provider.certpath.SunCertPathBuilderException: unable to find valid certification path to requested target";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}