package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)[\-\+]?JPY\s[\d,.]+`)
var str = `EUR 25,963.00 sferfg
EUR 26,020.50 sferfg
-JPY 20,365.00 sferfg
-HKD 29,996.00
JPY 21,295.00
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}