package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[(?:[^][]*|(?R))*\]`)
var str = `foo bar [first [second] [third]] asdf ]]]]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}