import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^.*openat(?:[\\s\\S]*)^.*hammad.*";
final String string = "[pid 20242] 23:13:36 futex(0x7f8087eb18, FUTEX_WAKE, 1 <unfinished ...>\n"
+ "[pid 621] 23:13:36 futex(0x7f80855410, FUTEX_WAIT, 1041, NULL <unfinished ...>\n"
+ "[pid 20242] 23:13:36 <... futex resumed> ) = 0\n"
+ "[pid 621] 23:13:36 <... futex resumed> ) = -1 EAGAIN (Try again)\n"
+ "[pid 20242] 23:13:36 munmap(0x7f80200000, 8192 <unfinished ...>\n"
+ "--> [pid 621] 23:13:36 openat(AT_FDCWD, \"/proc/self/task\", O_RDONLY|O_DIRECTORY|O_CLOEXEC <unfinished ...>\n"
+ "[pid 20242] 23:13:36 <... munmap resumed> ) = 0\n"
+ "[pid 621] 23:13:36 <... openat resumed> ) = 13\n"
+ "[pid 20242] 23:13:36 madvise(0x7f76a7b000, 20480, MADV_DONTNEED <unfinished ...>\n"
+ " --> [pid 621] 23:13:36 hammad(13, FUTEX_WAKE, 1, 24 )\n"
+ "[pid 20242] 23:13:36 madvise(0x7f76a7b000, 20480, MADV_DONTNEED <unfinished ...>\n"
+ "[pid 621] 23:13:36 <... futex resumed> ) = 0\n"
+ "[pid 20242] 23:13:36 futex(0x7f80855410, FUTEX_WAKE, 1 <unfinished ...>\n"
+ "[pid 621] 23:13:36 futex(0x7f8087eb18, FUTEX_WAKE, 1 <unfinished ...>\n"
+ "[pid 20242] 23:13:36 <... futex resumed> ) = 0\n"
+ "[pid 621] 23:13:36 <... futex resumed> ) = 0\n"
+ "[pid 20242] 23:13:36 futex(0x7f8087eb18, FUTEX_WAKE, 1 <unfinished ...>\n"
+ "[pid 621] 23:13:36 futex(0x7f80855410, FUTEX_WAIT, 1041, NULL <unfinished ...>\n"
+ "[pid 20242] 23:13:36 <... futex resumed> ) = 0";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}