$re = '/(?:[A-Z](?<!QW|WQ)(?<!Q(?=W)|W(?=Q)))+/m';
$str = 'ABCQWDEFWQXYZ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);