$re = '/abc(?!.*abc).*?\.xml/m';
$str = 'abcdefabcghi.xml
abcdefabc.xml
abc.xml
abcdefabcghi.xml test.xml.xml';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);