$re = '/\b(?=((?:[A-Z][a-z]+\s?\b){2}))/m';
$str = 'Expedition Runic Monster Markers';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);