$re = '/(?<=src=\')(.+?)(?=\')/m';
$str = '<img src=\'asdas\' alt=\'asdsad\'>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);