import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(25[0-5]|2[0-4][0-9]|1?[1-9]?[0-9])\\.(25[0-5]|2[0-4][0-9]|1?[1-9]?[0-9])\\.(25[0-5]|2[0-4][0-9]|1?[1-9]?[0-9])\\.(25[0-5]|2[0-4][0-9]|1?[1-9]?[0-9])$";
final String string = "10.0.0.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}