re = /https:\/\/cdn\.windwardstudios\.com\/Archive\/(\S+?)\/JavaRESTfulEngine-.*?\.zip/m
str = 'need to search for https://cdn.windwardstudios.com/Archive/23.X/23.3.0/JavaRESTfulEngine-23.3.0.32.zip url from https://www.windwardstudios.com/version/version-downloads using powershell.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end