$re = '/\b(?!cat\b)\w+/m';
$str = 'a black cat is scary catastrophy acat mcat catm';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);