// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)" *\R(*SKIP)(*FAIL)|\R"#).unwrap();
let string = "\"39901\",\"0002286898\",\"88\",\"ACTUALS\",\"TO RECORD ACCRUED LIABILITIES FOR GOODS OR SERVICES RECEIVED AT JUNE 30 2016 PER ATTACHED SCHEDULE. FOR 39901, IU journal 2297455 CONTACT: [NAME PHONE NUMBER] / [NAME PHONE NUMBER]\",\"LA\",\"34000000\",\"Accrued Liabilities\",\"\",\"11000\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"2017\",\"1\",\"191313.130\",\"07/28/2016\",\"07/01/2016\",\"\",\"Accrued Liabilities\",\"\"
\"39901\",\"0002290128\",\"7\",\"ACTUALS\",\"To record accrued liabilities for goods or services received at June 30, 2016 per the attached schedule.
Contact [NAME PHONE NUMBER EMAIL] or [NAME PHONE NUMBER EMAIL]\",\"LA\",\"34000000\",\"Accrued Liabilities\",\"\",\"11000\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"2017\",\"1\",\"2556242.170\",\"07/31/2016\",\"07/01/2016\",\"\",\"Accrued Liabilities\",\"\"
\"39901\",\"0002291224\",\"37\",\"ACTUALS\",\"TO RECORD ACCRUED LIABILITIES FOR GOODS OR SERVICES RECEIVED AT JUNE 30 PER THE ATTACHED SCHEDULE. FOR 34530, CONTACT: [NAME PHONE NUMBER EMAIL]\",\"LA\",\"34000000\",\"Accrued Liabilities\",\"\",\"11000\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"2017\",\"1\",\"3010262.140\",\"07/27/2016\",\"07/01/2016\",\"\",\"Accrued Liabilities\",\"\"
\"39901\",\"0002291259\",\"2\",\"ACTUALS\",\"TO RECORD ACCRUED LIABILITIES FOR GOODS OR SERVICES RECEIVED AT JUNE 30 PER THE ATTACHED SCHEDULE. FOR 34571, CONTACT: [NAME PHONE NUMBER] / [NAME PHONE NUMBER]\",\"LA\",\"34000000\",\"Accrued Liabilities\",\"\",\"11000\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"2017\",\"1\",\"38140.260\",\"07/27/2016\",\"07/01/2016\",\"\",\"Accrued Liabilities\",\"\"
\"39901\",\"0002291336\",\"12\",\"ACTUALS\",\"TO RECORD ACCRUED LIABILITIES FOR GOODS OR SERVICES RECEIVED AT JUNE 30 PER ATTACHED SCHEDULE. FOR 345.20\",\"LA\",\"34000000\",\"Accrued Liabilities\",\"\",\"11000\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"\",\"2017\",\"1\",\"2768000.000\",\"08/01/2016\",\"07/01/2016\",\"\",\"Accrued Liabilities\",\"\"";
let substitution = "";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}