import re
regex = re.compile(r"(?<!.*From: .*)([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)", flags=re.MULTILINE)
test_str = ("18.4.2019 9:35:02.115(22)->:From: address@subdomain.domain.tld\n"
"RCPT TO:<address@domain.tld>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")