re = /(?<!From: .*)([a-zA-Z0-9_.+-]+@[a-zA-Z0-9-]+\.[a-zA-Z0-9-.]+)/m
str = '18.4.2019 9:35:02.115(22)->:From: address@subdomain.domain.tld
RCPT TO:<address@domain.tld>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end