re = /(?<uuid>\[[0-9a-f]{8}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{4}-[0-9a-f]{12}\])$/m
str = 'Received task: worker.run_test[17a75c0e-9ff3-4895-8af1-8c4a16fc9527]'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end