// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?u)(\x{a9}|\x{ae}|[\x{2000}-\x{3300}]|[\x{1F000}-\x{1FBFF}])").unwrap();
let string = "๐ ๐ ๐ ๐คฃ ๐ ๐ ๐
๐ ๐ ๐ ๐ ๐ ๐ ๐ ๐ฅฐ ๐ ๐ ๐ โบ๏ธ ๐ ๐ค ๐คฉ ๐ค ๐คจ ๐ ๐ ๐ถ ๐ ๐ ๐ฃ ๐ฅ ๐ฎ ๐ค ๐ฏ ๐ช ๐ซ ๐ด ๐ ๐ ๐ ๐ ๐คค ๐ ๐ ๐ ๐ ๐ ๐ค ๐ฒ โน๏ธ ๐ ๐ ๐ ๐ ๐ค ๐ข ๐ญ ๐ฆ ๐ง ๐จ ๐ฉ ๐คฏ ๐ฌ ๐ฐ ๐ฑ ๐ฅต ๐ฅถ ๐ณ ๐คช ๐ต ๐ก ๐ ๐คฌ ๐ท ๐ค ๐ค ๐คข ๐คฎ ๐คง ๐ ๐ค ๐คก ๐ฅณ ๐ฅด ๐ฅบ ๐คฅ ๐คซ ๐คญ ๐ง ๐ค ๐ ๐ฟ ๐น ๐บ ๐ ๐ป ๐ฝ ๐ค ๐ฉ ๐บ ๐ธ ๐น ๐ป ๐ผ ๐ฝ ๐ ๐ฟ ๐พ
People and Fantasy
๐ถ ๐ง ๐ง ๐ฆ ๐ฉ ๐ง ๐จ ๐ต ๐ง ๐ด ๐ฒ ๐ณโโ๏ธ ๐ณโโ๏ธ ๐ง ๐ง ๐ฑโโ๏ธ ๐ฑโโ๏ธ ๐จโ๐ฆฐ ๐ฉโ๐ฆฐ ๐จโ๐ฆฑ ๐ฉโ๐ฆฑ ๐จโ๐ฆฒ ๐ฉโ๐ฆฒ ๐จโ๐ฆณ ๐ฉโ๐ฆณ ๐ฆธโโ๏ธ ๐ฆธโโ๏ธ ๐ฆนโโ๏ธ ๐ฆนโโ๏ธ ๐ฎโโ๏ธ ๐ฎโโ๏ธ ๐ทโโ๏ธ ๐ทโโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐ต๏ธโโ๏ธ ๐ต๏ธโโ๏ธ ๐ฉโโ๏ธ ๐จโโ๏ธ ๐ฉโ๐พ ๐จโ๐พ ๐ฉโ๐ณ ๐จโ๐ณ ๐ฉโ๐ ๐จโ๐ ๐ฉโ๐ค ๐จโ๐ค ๐ฉโ๐ซ ๐จโ๐ซ ๐ฉโ๐ญ ๐จโ๐ญ ๐ฉโ๐ป ๐จโ๐ป ๐ฉโ๐ผ ๐จโ๐ผ ๐ฉโ๐ง ๐จโ๐ง ๐ฉโ๐ฌ ๐จโ๐ฌ ๐ฉโ๐จ ๐จโ๐จ ๐ฉโ๐ ๐จโ๐ ๐ฉโโ๏ธ ๐จโโ๏ธ ๐ฉโ๐ ๐จโ๐ ๐ฉโโ๏ธ ๐จโโ๏ธ ๐ฐ ๐คต ๐ธ ๐คด ๐คถ ๐
๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐ผ ๐คฐ ๐คฑ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐
โโ๏ธ ๐
โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐คฆโโ๏ธ ๐คฆโโ๏ธ ๐คทโโ๏ธ ๐คทโโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐งโโ๏ธ ๐งโโ๏ธ ๐
๐คณ ๐ ๐บ ๐ฏโโ๏ธ ๐ฏโโ๏ธ ๐ด ๐ถโโ๏ธ ๐ถโโ๏ธ ๐โโ๏ธ ๐โโ๏ธ ๐ซ ๐ญ ๐ฌ ๐ ๐ฉโโค๏ธโ๐ฉ ๐จโโค๏ธโ๐จ ๐ ๐ฉโโค๏ธโ๐โ๐ฉ ๐จโโค๏ธโ๐โ๐จ ๐ช ๐จโ๐ฉโ๐ง ๐จโ๐ฉโ๐งโ๐ฆ ๐จโ๐ฉโ๐ฆโ๐ฆ ๐จโ๐ฉโ๐งโ๐ง ๐ฉโ๐ฉโ๐ฆ ๐ฉโ๐ฉโ๐ง ๐ฉโ๐ฉโ๐งโ๐ฆ ๐ฉโ๐ฉโ๐ฆโ๐ฆ ๐ฉโ๐ฉโ๐งโ๐ง ๐จโ๐จโ๐ฆ ๐จโ๐จโ๐ง ๐จโ๐จโ๐งโ๐ฆ ๐จโ๐จโ๐ฆโ๐ฆ ๐จโ๐จโ๐งโ๐ง ๐ฉโ๐ฆ ๐ฉโ๐ง ๐ฉโ๐งโ๐ฆ ๐ฉโ๐ฆโ๐ฆ ๐ฉโ๐งโ๐ง ๐จโ๐ฆ ๐จโ๐ง ๐จโ๐งโ๐ฆ ๐จโ๐ฆโ๐ฆ ๐จโ๐งโ๐ง ๐คฒ ๐ ๐ ๐ ๐ค ๐ ๐ ๐ โ ๐ค ๐ค ๐ค โ๏ธ ๐ค ๐ค ๐ ๐ ๐ ๐ ๐ โ๏ธ โ ๐ค ๐ ๐ ๐ ๐ค ๐ช ๐ฆต ๐ฆถ ๐ โ๏ธ ๐ ๐ ๐ ๐ ๐ ๐
๐ ๐ ๐ฃ ๐ ๐ ๐ง ๐ฆด ๐ฆท ๐ฃ ๐ค ๐ฅ
Clothing and Accessories
๐งฅ ๐ ๐ ๐ ๐ ๐ ๐ ๐ ๐ ๐ก ๐ข ๐ ๐ ๐ฅพ ๐ฅฟ ๐งฆ ๐งค ๐งฃ ๐ฉ ๐งข ๐ ๐ โ ๐ ๐ ๐ ๐ ๐ผ ๐ ๐ ๐ถ ๐ฅฝ ๐ฅผ ๐ ๐งต ๐งถ
Pale Emojis
๐ถ๐ป ๐ฆ๐ป ๐ง๐ป ๐จ๐ป ๐ฉ๐ป ๐ฑ๐ปโโ๏ธ ๐ฑ๐ป ๐ด๐ป ๐ต๐ป ๐ฒ๐ป ๐ณ๐ปโโ๏ธ ๐ณ๐ป ๐ฎ๐ปโโ๏ธ ๐ฎ๐ป ๐ท๐ปโโ๏ธ ๐ท๐ป ๐๐ปโโ๏ธ ๐๐ป ๐ต๐ปโโ๏ธ ๐ต๐ป ๐ฉ๐ปโโ๏ธ ๐จ๐ปโโ๏ธ ๐ฉ๐ปโ๐พ ๐จ๐ปโ๐พ ๐ฉ๐ปโ๐ณ ๐จ๐ปโ๐ณ ๐ฉ๐ปโ๐ ๐จ๐ปโ๐ ๐ฉ๐ปโ๐ค ๐จ๐ปโ๐ค ๐ฉ๐ปโ๐ซ ๐จ๐ปโ๐ซ ๐ฉ๐ปโ๐ญ ๐จ๐ปโ๐ญ ๐ฉ๐ปโ๐ป ๐จ๐ปโ๐ป ๐ฉ๐ปโ๐ผ ๐จ๐ปโ๐ผ ๐ฉ๐ปโ๐ง ๐จ๐ปโ๐ง ๐ฉ๐ปโ๐ฌ ๐จ๐ปโ๐ฌ ๐ฉ๐ปโ๐จ ๐จ๐ปโ๐จ ๐ฉ๐ปโ๐ ๐จ๐ปโ๐ ๐ฉ๐ปโโ๏ธ ๐จ๐ปโโ๏ธ ๐ฉ๐ปโ๐ ๐จ๐ปโ๐ ๐ฉ๐ปโโ๏ธ ๐จ๐ปโโ๏ธ ๐คถ๐ป ๐
๐ป ๐ธ๐ป ๐คด๐ป ๐ฐ๐ป ๐คต๐ป ๐ผ๐ป ๐คฐ๐ป ๐๐ปโโ๏ธ ๐๐ป ๐๐ป ๐๐ปโโ๏ธ ๐
๐ป ๐
๐ปโโ๏ธ ๐๐ป ๐๐ปโโ๏ธ ๐๐ป ๐๐ปโโ๏ธ ๐คฆ๐ปโโ๏ธ ๐คฆ๐ปโโ๏ธ ๐คท๐ปโโ๏ธ ๐คท๐ปโโ๏ธ ๐๐ป ๐๐ปโโ๏ธ ๐๐ป ๐๐ปโโ๏ธ ๐๐ป ๐๐ปโโ๏ธ ๐๐ป ๐๐ปโโ๏ธ ๐ด๐ป ๐๐ป ๐บ๐ป ๐ถ๐ปโโ๏ธ ๐ถ๐ป ๐๐ปโโ๏ธ ๐๐ป ๐คฒ๐ป ๐๐ป ๐๐ป ๐๐ป ๐๐ป ๐๐ป ๐๐ป ๐๐ป โ๐ป ๐ค๐ป ๐ค๐ป ๐ค๐ป โ๐ป ๐ค๐ป ๐ค๐ป ๐๐ป ๐๐ป ๐๐ป ๐๐ป ๐๐ป โ๐ป โ๐ป ๐ค๐ป ๐๐ป ๐๐ป ๐๐ป ๐ค๐ป ๐ช๐ป ๐๐ป โ๐ป ๐คณ๐ป ๐
๐ป ๐๐ป ๐๐ป
Cream White Emojis
๐ถ๐ผ ๐ฆ๐ผ ๐ง๐ผ ๐จ๐ผ ๐ฉ๐ผ ๐ฑ๐ผโโ๏ธ ๐ฑ๐ผ ๐ด๐ผ ๐ต๐ผ ๐ฒ๐ผ ๐ณ๐ผโโ๏ธ ๐ณ๐ผ ๐ฎ๐ผโโ๏ธ ๐ฎ๐ผ ๐ท๐ผโโ๏ธ ๐ท๐ผ ๐๐ผโโ๏ธ ๐๐ผ ๐ต๐ผโโ๏ธ ๐ต๐ผ ๐ฉ๐ผโโ๏ธ ๐จ๐ผโโ๏ธ ๐ฉ๐ผโ๐พ ๐จ๐ผโ๐พ ๐ฉ๐ผโ๐ณ ๐จ๐ผโ๐ณ ๐ฉ๐ผโ๐ ๐จ๐ผโ๐ ๐ฉ๐ผโ๐ค ๐จ๐ผโ๐ค ๐ฉ๐ผโ๐ซ ๐จ๐ผโ๐ซ ๐ฉ๐ผโ๐ญ ๐จ๐ผโ๐ญ ๐ฉ๐ผโ๐ป ๐จ๐ผโ๐ป ๐ฉ๐ผโ๐ผ ๐จ๐ผโ๐ผ ๐ฉ๐ผโ๐ง ๐จ๐ผโ๐ง ๐ฉ๐ผโ๐ฌ ๐จ๐ผโ๐ฌ ๐ฉ๐ผโ๐จ ๐จ๐ผโ๐จ ๐ฉ๐ผโ๐ ๐จ๐ผโ๐ ๐ฉ๐ผโโ๏ธ ๐จ๐ผโโ๏ธ ๐ฉ๐ผโ๐ ๐จ๐ผโ๐ ๐ฉ๐ผโโ๏ธ ๐จ๐ผโโ๏ธ ๐คถ๐ผ ๐
๐ผ ๐ธ๐ผ ๐คด๐ผ ๐ฐ๐ผ ๐คต๐ผ ๐ผ๐ผ ๐คฐ๐ผ ๐๐ผโโ๏ธ ๐๐ผ ๐๐ผ ๐๐ผโโ๏ธ ๐
๐ผ ๐
๐ผโโ๏ธ ๐๐ผ ๐๐ผโโ๏ธ ๐๐ผ ๐๐ผโโ๏ธ ๐คฆ๐ผโโ๏ธ ๐คฆ๐ผโโ๏ธ ๐คท๐ผโโ๏ธ ๐คท๐ผโโ๏ธ ๐๐ผ ๐๐ผโโ๏ธ ๐๐ผ ๐๐ผโโ๏ธ ๐๐ผ ๐๐ผโโ๏ธ ๐๐ผ ๐๐ผโโ๏ธ ๐ด๐ผ ๐๐ผ ๐บ๐ผ ๐ถ๐ผโโ๏ธ ๐ถ๐ผ ๐๐ผโโ๏ธ ๐๐ผ ๐คฒ๐ผ ๐๐ผ ๐๐ผ ๐๐ผ ๐๐ผ ๐๐ผ ๐๐ผ ๐๐ผ โ๐ผ ๐ค๐ผ ๐ค๐ผ ๐ค๐ผ โ๐ผ ๐ค๐ผ ๐ค๐ผ ๐๐ผ ๐๐ผ ๐๐ผ ๐๐ผ ๐๐ผ โ๐ผ โ๐ผ ๐ค๐ผ ๐๐ผ ๐๐ผ ๐๐ผ ๐ค๐ผ ๐ช๐ผ ๐๐ผ โ๐ผ ๐คณ๐ผ ๐
๐ผ ๐๐ผ ๐๐ผ
Moderate Brown Emojis
๐ถ๐ฝ ๐ฆ๐ฝ ๐ง๐ฝ ๐จ๐ฝ ๐ฉ๐ฝ ๐ฑ๐ฝโโ๏ธ ๐ฑ๐ฝ ๐ด๐ฝ ๐ต๐ฝ ๐ฒ๐ฝ ๐ณ๐ฝโโ๏ธ ๐ณ๐ฝ ๐ฎ๐ฝโโ๏ธ ๐ฎ๐ฝ ๐ท๐ฝโโ๏ธ ๐ท๐ฝ ๐๐ฝโโ๏ธ ๐๐ฝ ๐ต๐ฝโโ๏ธ ๐ต๐ฝ ๐ฉ๐ฝโโ๏ธ ๐จ๐ฝโโ๏ธ ๐ฉ๐ฝโ๐พ ๐จ๐ฝโ๐พ ๐ฉ๐ฝโ๐ณ ๐จ๐ฝโ๐ณ ๐ฉ๐ฝโ๐ ๐จ๐ฝโ๐ ๐ฉ๐ฝโ๐ค ๐จ๐ฝโ๐ค ๐ฉ๐ฝโ๐ซ ๐จ๐ฝโ๐ซ ๐ฉ๐ฝโ๐ญ ๐จ๐ฝโ๐ญ ๐ฉ๐ฝโ๐ป ๐จ๐ฝโ๐ป ๐ฉ๐ฝโ๐ผ ๐จ๐ฝโ๐ผ ๐ฉ๐ฝโ๐ง ๐จ๐ฝโ๐ง ๐ฉ๐ฝโ๐ฌ ๐จ๐ฝโ๐ฌ ๐ฉ๐ฝโ๐จ ๐จ๐ฝโ๐จ ๐ฉ๐ฝโ๐ ๐จ๐ฝโ๐ ๐ฉ๐ฝโโ๏ธ ๐จ๐ฝโโ๏ธ ๐ฉ๐ฝโ๐ ๐จ๐ฝโ๐ ๐ฉ๐ฝโโ๏ธ ๐จ๐ฝโโ๏ธ ๐คถ๐ฝ ๐
๐ฝ ๐ธ๐ฝ ๐คด๐ฝ ๐ฐ๐ฝ ๐คต๐ฝ ๐ผ๐ฝ ๐คฐ๐ฝ ๐๐ฝโโ๏ธ ๐๐ฝ ๐๐ฝ ๐๐ฝโโ๏ธ ๐
๐ฝ ๐
๐ฝโโ๏ธ ๐๐ฝ ๐๐ฝโโ๏ธ ๐๐ฝ ๐๐ฝโโ๏ธ ๐คฆ๐ฝโโ๏ธ ๐คฆ๐ฝโโ๏ธ ๐คท๐ฝโโ๏ธ ๐คท๐ฝโโ๏ธ ๐๐ฝ ๐๐ฝโโ๏ธ ๐๐ฝ ๐๐ฝโโ๏ธ ๐๐ฝ ๐๐ฝโโ๏ธ ๐๐ฝ ๐๐ฝโโ๏ธ ๐ด๐ผ ๐๐ฝ ๐บ๐ฝ ๐ถ๐ฝโโ๏ธ ๐ถ๐ฝ ๐๐ฝโโ๏ธ ๐๐ฝ ๐คฒ๐ฝ ๐๐ฝ ๐๐ฝ ๐๐ฝ ๐๐ฝ ๐๐ฝ ๐๐ฝ ๐๐ฝ โ๐ฝ ๐ค๐ฝ ๐ค๐ฝ ๐ค๐ฝ โ๐ฝ ๐ค๐ฝ ๐ค๐ฝ ๐๐ฝ ๐๐ฝ ๐๐ฝ ๐๐ฝ ๐๐ฝ โ๐ฝ โ๐ฝ ๐ค๐ฝ ๐๐ฝ ๐๐ฝ ๐๐ฝ ๐ค๐ฝ ๐ช๐ฝ ๐๐ฝ โ๐ฝ ๐คณ๐ฝ ๐
๐ฝ ๐๐ฝ ๐๐ฝ
Dark Brown Emojis";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}