$re = '/^\D:(\\\\\w+\\\\\w+(\\\\?))$/m';
$str = 'C:\\folder1\\folder2
C:\\folder1\\folder2\\
C:\\folder1\\folder2\\file1.txt
C:\\folder1\\folder2\\file2.docx
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);