$re = '/(?<=and\s)(Oniguruma)(?=\s+regular)/m';
$str = 'VS Code, TextMate grammars, and Oniguruma regular expressions. ';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);