#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?mi)(^## assemble\/assemble-boilerplate-markdown starts)([\s\S]*?)(^## assemble\/assemble-boilerplate-markdown ends)"
Local $sString = "## assemble/assemble-boilerplate-markdown starts" & @CRLF & _
"" & @CRLF & _
"## assemble/assemble-boilerplate-markdown ends" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"## assemble/assemble-boilerplate-markdown starts " & @CRLF & _
"" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/TOC" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/auto-links" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/autolink-lines" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/backslash-escapes" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/blockquote-list-item" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/blockquotes-with-code-blocks" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/case-insensitive-refs" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/code-blocks" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/code-spans" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/def-blocks" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/double-link" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/escaped-angles" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/gfm-break" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/gfm-code-hr-list" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/gfm-code" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/gfm-del" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/gfm-em" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/gfm-links" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/gfm-tables" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/hard-wrapped-paragraphs-with-list-like-lines" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/horizontal-rules" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/hr-list-break" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/inline-html-advanced" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/inline-html-comments" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/inline-html-simple" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/lazy-blockquotes" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/links-inline-style" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/links-reference-style" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/links-shortcut-references" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/list-item-text" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/literal-quotes-in-titles" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/loose-lists" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/main" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/markdown-documentation-basics" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/markdown-documentation-syntax" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/nested-blockquotes" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/nested-code" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/nested-em" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/nested-square-link" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/not-a-link" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/ordered-and-unordered-lists" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/same-bullet" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/markdown/strong-and-em-together" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/data-context" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/data-types" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/data-yaml-front-matter" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/data-yaml" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/data" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options-assets" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options-collections" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options-data" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options-engine" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options-ext" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options-helpers" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options-layout" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options-layoutdir" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options-partials" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/options" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/templates-helpers" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/templates-layouts" & @CRLF & _
"/assemble-boilerplate-markdown/src/content/wiki/templates-partials" & @CRLF & _
"" & @CRLF & _
"## assemble/assemble-boilerplate-markdown ends"
Local $sSubst = "xxx"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)