#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)^(?:(?:https?:)?\/\/)?(?:(?:(?:www|m(?:usic)?)\.)?youtu(?:\.be|be\.com)\/(?:shorts\/|live\/|v\/|e(?:mbed)?\/|watch(?:\/|\?(?:\S+=\S+&)*v=)|oembed\?url=https?%3A\/\/(?:www|m(?:usic)?)\.youtube\.com\/watch\?(?:\S+=\S+&)*v%3D|attribution_link\?(?:\S+=\S+&)*u=(?:\/|%2F)watch(?:\?|%3F)v(?:=|%3D))?|www\.youtube-nocookie\.com\/embed\/)([\w-]{11})[\?&#]?\S*$"
Local $sString = " various protocols (and lack of one):" & @CRLF & _
"https://www.youtube.com/watch?v=U9t-slLl30E" & @CRLF & _
"http://www.youtube.com/watch?v=U9t-slLl30E" & @CRLF & _
"//www.youtube.com/watch?v=U9t-slLl30E" & @CRLF & _
"www.youtube.com/watch?v=U9t-slLl30E" & @CRLF & _
"" & @CRLF & _
" and for each protocol" & @CRLF & _
" various domains:" & @CRLF & _
"www.youtube.com/watch?v=U9t-slLl30E" & @CRLF & _
"m.youtube.com/watch?v=U9t-slLl30E" & @CRLF & _
"music.youtube.com/watch?v=OD3F7J2PeYU" & @CRLF & _
"youtube.com/watch?v=U9t-slLl30E" & @CRLF & _
"www.youtube-nocookie.com/embed/U9t-slLl30E" & @CRLF & _
"youtu.be/U9t-slLl30E" & @CRLF & _
"" & @CRLF & _
" and for each domain (despite -nocookie)" & @CRLF & _
" various paths:" & @CRLF & _
"youtube.com/watch?v=U9t-slLl30E" & @CRLF & _
"youtube.com/watch/U9t-slLl30E" & @CRLF & _
"youtube.com/v/U9t-slLl30E" & @CRLF & _
"youtube.com/embed/U9t-slLl30E" & @CRLF & _
"youtube.com/e/U9t-slLl30E" & @CRLF & _
"youtube.com/live/9UMxZofMNbA" & @CRLF & _
"youtube.com/shorts/gOcxEMJSksg" & @CRLF & _
"youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3DU9t-slLl30E&format=json" & @CRLF & _
"youtube.com/attribution_link?a=JdfC0C9V6ZI&u=%2Fwatch%3Fv%3DU9t-slLl30E%26feature%3Dshare" & @CRLF & _
"youtube.com/attribution_link?a=8g8kPrPIi-ecwIsS&u=/watch%3Fv%3DU9t-slLl30E%26feature%3Dem-uploademail" & @CRLF & _
"" & @CRLF & _
" and for each path" & @CRLF & _
" various parameters:" & @CRLF & _
"youtube.com/watch?v=U9t-slLl30E" & @CRLF & _
"youtube.com/watch?v=U9t-slLl30E&feature=shared" & @CRLF & _
"youtube.com/watch?v=U9t-slLl30E&t=1m02s" & @CRLF & _
"youtube.com/watch?v=U9t-slLl30E&lc=UgyYsn3aIQWSA19Esi54AaABAg" & @CRLF & _
"youtube.com/watch?v=Lo2qQmj0_h4&list=PLmXxqSJJq-yVWpRFGImHYZBQTuBGLjG4t&index=5&pp=iAQB8AUB" & @CRLF & _
" in various order:" & @CRLF & _
"youtube.com/watch?feature=shared&v=U9t-slLl30E" & @CRLF & _
"" & @CRLF & _
" but not these:" & @CRLF & _
"(wrong ID)" & @CRLF & _
"youtube.com/watch?v=U$t-slLl30E" & @CRLF & _
"(too short ID)" & @CRLF & _
"youtube.com/watch?v=U9t-slLl30&t=10" & @CRLF & _
"(wrong or deprecated paths)" & @CRLF & _
"youtube.com/GitHub?v=U9t-slLl30E" & @CRLF & _
"youtube.com/?v=U9t-slLl30E" & @CRLF & _
"youtube.com/?vi=U9t-slLl30E" & @CRLF & _
"youtube.com/?feature=player_embedded&v=U9t-slLl30E" & @CRLF & _
"youtube.com/watch?vi=U9t-slLl30E" & @CRLF & _
"youtube.com/vi/U9t-slLl30E" & @CRLF & _
"(www.youtube-nocookie.com/embed/ only!)" & @CRLF & _
"youtube-nocookie.com/embed/U9t-slLl30E" & @CRLF & _
"www.youtube-nocookie.com/watch?v=U9t-slLl30E" & @CRLF & _
"http://www.youtube-nocookie.com/v/U9t-slLl30E?version=3&hl=en_US&rel=0" & @CRLF & _
"(playlist)" & @CRLF & _
"youtube.com/playlist?list=PLmXxqSJJq-yVWpRFGImHYZBQTuBGLjG4t"
Local $sSubst = "https://www.youtube.com/watch?v=XGkm-6yCIio"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)