re = /[^\S\n]+(?=\d{5,7}\b)/m
str = '1338516 -...pair - 5pk 1409093 -...re Wax 3Pk
1409085 -...dtnr - 5pk 1415090 -...accessories
490663 - 3 pack 1490739 -...2 - 3 pack'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end