re = /^((http|https)(:\/\/www.foo.com)(\/.*))|(sc-domain:www.foo.com)$/m
str = 'https://www.foo.com/
https://www.foo.com/bar/
sc-domain:www.foo.com
http://www.foo.com/
http://www.foo.com/bar/
htps://www.foo.com/
https:/www.foo.com/bar/
sc-domain:www.foo.com/
sc-domain:www.foo.com/bar
scdomain:www.foo.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end