#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^.*?(?=\s[\d]|\s[A-Z]{2,})"
Local $sString = "Tortillas Bolsa 2a 1kg 4118" & @CRLF & _
"Tortillinas 50p 1 31Kg TAB TR 46113" & @CRLF & _
"Bollos BK 4in 36p 1635g SL 131" & @CRLF & _
"Super Pan Bco Ajonjoli 680g SP WON 100 " & @CRLF & _
"Pan Blanco Bimbo Rendidor 567g BIM 49973" & @CRLF & _
"Gansito ME 5p 250g MTA MLA 49860"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")