$re = '/^(\w+(?:\s{1,2}\w+)*)\s+(.*?)\s+(\d+(?:[.,]\d+)*)$/m';
$str = 'word1 word2                  word3 word4                   1234.23,4';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);