re = /.*\]\s*(?<msg>[^:]+)/m
str = '][ERROR][pub-#32738][AssociationRemoteProcessor] Exception while running association: javax.cache.CacheException: class org.apache.ignite.IgniteInterrup
[2023-11-09T06:06:02,015][ERROR][pub-#19230][FedPledgingFlaggingRemoteProcessor] No rejection criteria found for the specified key: CO.'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end