re = /sm-mta.*to=\K|\G(?!^).+?@(.+?)[>, ]/m
str = 'Aug 15 00:01:06 **** sm-mta*** to=<user1@gmail.com>,<user2@yahoo.com>,user3@aol.com, some_more_stuff
Aug 16 13:16:09 **** sendmail*** to=<user4@yahoo.com>, some_more_stuff
Aug 17 11:14:48 **** sm-mta*** to=<user5@gmail.com>,<user6@gmail.com>, some_more_stuff'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end