const regex = /^(?:(?<title>(?:\S+\.)+) +)*(?<first>\S+)(?: *(?<middle>[^,\n\r]+)*? +(?<last>[^,\s]+)*)*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:(?<title>(?:\\S+\\.)+) +)*(?<first>\\S+)(?: *(?<middle>[^,\\n\\r]+)*? +(?<last>[^,\\s]+)*)*$', 'gm')
const str = `Ryan
Ryan William
Ryan William Toner
Mr. Ryan William Toner
Ryan William Corey Toner
Ryan William Corey Toner, Jr
Mr. Ryan William Corey Toner, Jr.`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}