re = /^(A+).*[^A]\1$/m
str = 'AA4grgrsragrga4334grAAA
AAA4323425AAA
AAAAAA%%%AAAAAA'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end