const regex = /-/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('-', 'g')
const str = `4581-4582-4583-4584`;
const subst = `\n`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);