import re
regex = re.compile(r"(?=(?!^)(?:\d{4})+$)")
test_str = "4581458245834584"
subst = "-"
result = regex.sub(subst, test_str)
if result:
print(result)