re = /[(^?&#)]([^=]+)\=([^&#]+)/
str = 'https://www.heatingspareparts.com/Boiler-Spares/AllPartsFor/Baxi?Search=a&page=1&more=2#hash'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end