const regex = /(?<=\s)(?:\d+[-](?=\d))+\d+(?=\s)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<=\\s)(?:\\d+[-](?=\\d))+\\d+(?=\\s)', 'g')
const str = `то есть, матчится:
111-111
11-1111
1-111-11
не матчится:
111111
-111111
111111-
111--111
11-11
1111-1111
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}