const regex = /^D7[4]{1}............/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^D7[4]{1}............', 'gm')
const str = `D74000000016CCC
D7400000001813B
D7400000001991B
D74000000019E07
D74000000019F99
D7400000001A4A4
D7400000001A53E
D7400000001A5C2
D7500000008E44C
D7500000008F94E
D750000000901B2
D75000000095FB1
D7500000009B218
D750000000A36E1
D750000000AD9AA
D750000001135DB
D75000000118DC1
D75000000119E91
D75............
D74............
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}