# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^[\dA-F]+[ \t]+[\dA-F]+(?: [\dA-F]+)*[ \t]+"
test_str = ("0 4D1F 8172 DC.L $4D1F8172 ; Rom CheckSum\n"
"4 0040 002A DC.L $0040002A ; Boot Vector = EBootStart\n"
"8 00 DC.B $00 ; Machine Type\n"
"9 75 DC.B $75 ; Rom Version\n"
"A 6000 0056 Bra L3\n"
"E 6000 0750 Bra L62\n"
"12 6000 0044 Bra L2\n"
"16 6000 0016 Bra E_6\n"
"1A 0001 76F8 DC.L $000176F8 ; offset of Resources in ROM\n"
"1E 4EFA 2BFC Jmp P_mvDoEject\n"
"22 0000 0000 DC.L $00000000\n"
"26 0000 0000 DC.L $00000000\n\n"
"1FFE2 4B57 4B20 4C41 DC.B 'KWK LA'")
matches = re.finditer(regex, test_str, re.MULTILINE | re.IGNORECASE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.