use strict;
my $str = 'any text here my text any text word wrong any text
any text here my text any text true any text
any text here my text any text wrong any text';
my $regex = qr/here((?:(?!\bword\b)[a-z ,]){0,70}) (wrong|true) /mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}