# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<!\S)(?<!\d\d\d\d )\$?\d{1,3}(?:[. ]\d\d)?(?!\S)"
test_str = ("123\n"
"123.45\n"
"12 34\n"
"$12 34\n"
"$123\n"
"$1.23\n\n"
"9999\n"
"99.999\n"
"99.9\n"
"12345\n\n"
"123 12 123 12\n\n\n"
" I paid $199.99 for the purchase id 123456 and phone number 1234 3456 5678")
subst = "dummy_price"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.