$re = '/\b[^\W\d]\w*+(?!\()/';
$str = 'a3+red+42+_dv+Sy(w12+44)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);