import re
regex = re.compile(r"(?<=\s)x(?=\s\d?)")
test_str = ("apple 10m\n"
"10mm\n"
"11ml\n"
"11kg\n"
"12g\n"
"13gr\n"
"14m3\n"
"15m2\n\n"
"apple 10 stuks \n"
"10 pieces\n"
"11 pces\n"
"11 pce\n"
"12 stk\n"
"13 stuks\n"
"14m3\n"
"15m2\n\n"
"ml x 1\n"
"ml X 10m")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")