$re = '/(0x|0X)([0-9a-fA-F]+)/m';
$str = '0x123
0X01233332ffFFF';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);