// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^gallery/country(?:/[^/]*([a-zA-Z-9]{2}))?/?$").unwrap();
let string = "gallery/country
gallery/country/
gallery/country/ie
gallery/country/ie/
gallery/country/ireland
gallery/country/ireland/
gallery/country/ireland-love.ie
gallery/country/ireland-love.ie/
gallery/country/ireland.69-love.ie/";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}