# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(Bundle can be downloaded at : http:\\/\\/\*)(\\/downloads\\/[[:xdigit:]]{8}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{4}-[[:xdigit:]]{12}\\/configBundle-.+?)(\.tgz)$/\/scratch$2.timestamp$3/gm;t' <<< "Bundle can be downloaded at : http://*/downloads/52aa233b-5db4-2298-5e1b-f510b2cd149f/configBundle-ESXi-X10SRH-CF.tgz"