package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[^\s]{1}`)
var str = `Кира
Лена
Donald`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}