re = /\b[^2\n]\d{6,12}\b/
str = '21234567
99912234
19123809
21234567
21234567
21234567
21234567
21234567
21234567
21234567'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end